Error installing SCOM 2012 Admin Console


Recently while working with a customer, the need arose to install the SCOM Admin console on a jump server used by some SQL Administrators. This particular customer is running SCOM 2012 RTM, without any service packs or cumulative updates/rollups. The installation of the SCOM 2012 Administration console, which is normally a pretty easy and smooth operation failed pretty quickly. Looking at the setup log, I found the following:

 

[10:05:09]: Debug: :LaunchMsi: Turning off the internal UI for C:\Users\Andres\Desktop\SystemCenterOpsManager2012\Setup\AMD64\Console\OMConsole.msi.

[10:05:09]: Debug: :LaunchMSI: Enable logging for the MSI at C:\Users\Andres.da\AppData\Local\SCOM\Logs\OMConsole.log.

[10:05:09]: Debug: :LaunchMsi: MSI C:\Users\Andres\Desktop\SystemCenterOpsManager2012\Setup\AMD64\Console\OMConsole.msi is not in silent mode. Setting the external UI.

[10:05:09]: Always: :LaunchMsi: Launching C:\Users\Andres\Desktop\SystemCenterOpsManager2012\Setup\AMD64\Console\OMConsole.msi

[10:05:09]: Always: :MsiInstallProduct finished for msi C:\Users\Andres\Desktop\SystemCenterOpsManager2012\Setup\AMD64\Console\OMConsole.msi.

[10:05:09]: Always: :LaunchMSI: Setting rollback to true

[10:05:09]: Error: :LaunchMSI: MSI C:\Users\Andres\Desktop\SystemCenterOpsManager2012\Setup\AMD64\Console\OMConsole.msi returned error 1603

[10:05:09]: Error: :ProcessInstalls: Install Item Operations console failed to install. We did not launch the post process delegate.

 

Researching the error did not turn up much, so I examined the rest of the server. I found that somehow this machine had the Microsoft Monitoring Agent installed and listed in Add/Remove Programs. This was puzzling because the name of the agent indicates SCOM 2012 R2 or better, when the agent's service name was changed. The puzzling part is that my customer's Operations Manager deployment was only 2012 RTM, with no updates or service packs. We uninstalled the SCOM 2012 Microsoft Monitoring Agent component, and then kicked off the installation of the Operations Manager Console, and this time it worked like a charm.

Going back to the log file I did see an entry of:

 

[09:53:48]: Debug: :CheckIfOperationsManagerIsInstalled: Agent found

[09:53:48]: Error: :IsValidToInstall: Agent found on this box. We cannot install

 

However, the installation did not halt because of the entries above. The only thing that happened was that the Operations Manager Management Server role was grayed out during the setup wizard. This was not a big deal for me, since we were not looking to install a Management Server. Nevertheless, the installation did not halt despite the entries above, and on the contrary, it attempted to install the Management Console component, then failed.


Comments (1)

  1. Barry! says:

    your blog is awesome! you rule!

Skip to main content