Unable to start User Profile Service Application – Starting


The User Profile Synchronization service for SharePoint 2010 or 2013 can fail to start for numerous reasons. This post is for when the User Profile Service Application(UPA) is stuck on Starting. This prevents anybody from creating connections or syncing users.


This will prevent the User Profile Service Application from functioning properly. ULS shows the topology.svc tossing this "The requested application could not be found" with EventID evr4.

We can try to start the by running the Provision method to get the service application Started.

$upa = Get-SPServiceApplication <GUID of Service Application>

$upa.Provision()

This did fail and in the ULS logs we found this entry.

05/26/2018 11:13:46.90    PowerShell_ISE.exe (0x4AF4)    0x48F4    SharePoint Portal Server    User Profiles    ojxm    High    SSP administration site owner is 'i:0#.w|oldaccount\deleted'.    018afcc8-f800-0001-5e35-00e1678bd301

SSP administration is a blast from the past. The reference is back to 2007 but service applications replaced the SSP in SharePoint 2010. This entry is stating we're looking for owner of the Central Admin. This value can be exposed by using PowerShell as well.

$site = Get-SPSite http://centralAdmin:1234

$site.Owner

 

Or the UI with Site Settings and Site Collection Administrators

Or the Change site collection administrators in Central Admin

 

Find that account there and replace it with a valid account then run the Provision() PowerShell.

 

 


Comments (0)

Skip to main content